jar_ohty: (Default)
[personal profile] jar_ohty
 Решение вроде бы очевидно -- добавить в командную строку ядра параметр "noefi", но ядро тогда не грузится, потому что поддержка EFI отключена. Чтобы загрузить-таки систему с "noefi", делаем следующее:
1. Вызываем SETUP при старте, нажав F2;
2. В меню "Boot" видим, что первым пунктом у нас стоит "ubuntu", а где-то ниже есть название жесткого диска. Этот пункт и надо поставить первым.
3. Наблюдаем глюк с зависанием стартового экрана EFI или кракозябрами, не пугаемся и нажимаем Enter (к сожалению, так придется делать на каждой загрузке) и попадаем в grub
4. Нажимаем e и дописываем в строку параметров ядра noefi, нажимаем F10.
5. В загруженной системе убеждаемся, что ждущий режим работает. Дописываем noefi в командную строку ядра в файле /etc/default/grub и делаем sudo update-grub. 
В результате выключение, перезагрузка и ждущий режим работает. Suspend to disk же вызывает неприятный эффект: после включения ничего не грузится, в SETUP и меню загрузки попасть нельзя. Грузится grub и в нем надо нажать на e, убрать noefi и нажать F10. Система загрузится, но до перезагрузки в ней опять не будет работать выключение, sleep mode и перезагрузка.

Date: 2011-07-24 06:14 am (UTC)
From: [identity profile] lliapuk.livejournal.com
>2. В меню "Boot" видим, что первым пунктом у нас стоит "ubuntu", а где-то ниже есть название жесткого диска. Этот пункт и надо поставить первым.

Можно, пожалуйста, поподробнее? Там только устройства, с которых загрузка идёт.


Ну и мне очень интересно:
Поставил Debian, GRUB-Legacy работает, Lilo тоже работает. GRUB2 зависает - ну и чёрт с ним.
Но при загрузке, на этапе подгрузки модулей DRM экран покрывается цветным снегом и система не реагирует даже на Ctrl+Alt+Del. Была ли такая проблема?

Date: 2011-07-24 07:29 pm (UTC)
From: [identity profile] jar-ohty.livejournal.com
Если загрузка GRUB2 идет через партицию EFI -- то будет относящийся к нему пункт меню. Если его нет, вы грузитесь "старым" способом. Это подтверждается тем, что не грузится GRUB2. То, что грузится старый GRUB и LILO -- наблюдение интересное, не догадался. Попробуйте поставить noefi в строку загрузки ядра, есть вероятность, что все заработает сразу.
Что касается модулей DRM -- имеются в виду ATIшные? Какая у вас версия ядра? У меня 2.6.38 и такой проблемы нет.

Date: 2011-07-25 06:51 am (UTC)
From: [identity profile] lliapuk.livejournal.com
Вообще-то проблема уже решилась установкой Debian Stable с последующим обновлением до Debian Sid. Если же сразу ставить Debian Sid - то такая картина наблюдается. Та же картина с Parted Magic - цветастый артефакт на весь экран.

Date: 2011-09-20 07:58 am (UTC)
From: [identity profile] mikola sevruk (from livejournal.com)
Дорогой Ясь, протанцевал с бубном вокруг UEFI пол дня и ничего не дало, дел все так как вы описываете,- и ничего, GRUB2 так и не грузится!!!
Что-то подскажыте?

February 2013

S M T W T F S
     1 2
3 456789
101112131415 16
17181920212223
2425262728  

Style Credit

Expand Cut Tags

No cut tags
Page generated Sep. 25th, 2017 12:38 am
Powered by Dreamwidth Studios